Monitasoinen numeroitu luettelo Excelissä

Monitasoinen numeroitu luettelo Excelissä

Oletko joskus kaivannut monitasoista numeroitua luetteloa Excelissä?

Voit ladata itsellesi tämän jutun lopusta tiedoston, johon on toteutettu monitasoisen luettelon esimerkkikaavat.

Idea

Aiheet syötetään D ja E -sarakkeisiin. Soluihin A2, B2 ja C2 luodut kaavat on kopioitu alas ja niiden perusteella muodostetaan numerointi sellaisille riveille, joille on syötetty aiheita. A- ja B-sarakkeet on tarkoitus piilottaa näkyviltä.

otsikoiden syöttö

Solun A2 kaava

A-sarakkeeseen lasketaan miten monta otsikkoa D-sarakkeeseen on syötetty kyseiselle riville asti.

=COUNTA( $D$2:D2 )
=LASKE.A( $D$2:D2 )

Solun B2 kaava

B-sarakkeessa on laskuri, joka aloittaa numeroinnin aina nollasta (0), kun aiheluetteloon on syötetty uusi aihe.

=IF( A2<>A1; 0; B1+1 )
=JOS( A2<>A1; 0; B1+1 )

Solun C2 kaava

Jos D-sarakkeessa on tekstiä, soluun sijoitetaan A-sarakkeessa oleva numero. Jos E-sarakkeessa on tekstiä, muodostetaan numero sekä A- että B-sarakkeiden avulla. Jos kummassakaan sarakkeessa ei ole tekstiä, jätetään solu tyhjäksi.

=IF( ISTEXT(D2);  A2;  IF( ISTEXT(E2); A2 & ”.” & B2; ”” ) )
=JOS( ONTEKSTI(D2);  A2;  JOS( ONTEKSTI(E2); A2 & ”.” & B2; ”” ) )

Esimerkkitiedosto

Lataa tiedosto: Monitasoinen luetteloesimerkki.xlsx

Esimerkkitiedoston C-sarakkeessa on ehdollinen muotoilu (conditional formatting), joka lihavoi numeeriset solut eli 1-tason aiheiden numerot. D-sarake on lihavoitu tavallisen muotoilun avulla.

Vastaa

Täytä tietosi alle tai klikkaa kuvaketta kirjautuaksesi sisään:

WordPress.com-logo

Olet kommentoimassa WordPress.com -tilin nimissä. Log Out / Muuta )

Twitter-kuva

Olet kommentoimassa Twitter -tilin nimissä. Log Out / Muuta )

Facebook-kuva

Olet kommentoimassa Facebook -tilin nimissä. Log Out / Muuta )

Google+ photo

Olet kommentoimassa Google+ -tilin nimissä. Log Out / Muuta )

Muodostetaan yhteyttä palveluun %s